import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^The thing is.*\\b(S\\d)(?!.*\\b(?:blue|red)\\b)";
final String string = "TRUE\n"
+ "The thing is S2w697 and green\n"
+ "The thing is S2e697 and yellow\n"
+ "The thing is S2b697 and pink\n\n"
+ "FALSE\n"
+ "The thing is S25697 and blue\n"
+ "The thing is S256b7 and red\n"
+ "The thing is S2e697 and blue thing\n"
+ "The thing is S2b697 and red thing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}