$re = '/^The thing is.*\b(S\d)(?!.*\b(?:blue|red)\b)/m';
$str = 'TRUE
The thing is S2w697 and green
The thing is S2e697 and yellow
The thing is S2b697 and pink
FALSE
The thing is S25697 and blue
The thing is S256b7 and red
The thing is S2e697 and blue thing
The thing is S2b697 and red thing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);