#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?=\w*[Aa])(?=\w*[Ee])(?=\w*[Ii])(?=\w*[Oo])(?=\w*[Uu])\w+\b"
Local $sString = "abceioussa" & @CRLF & _
"aeiou" & @CRLF & _
"uioae" & @CRLF & _
"odsidsfusjldkfuuuu" & @CRLF & _
"bcesdddsoaiaaau" & @CRLF & _
"aaaaaaaaeeeeeeeooooiu" & @CRLF & _
"aasssssaeeeeeeeoeoooi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")