$re = '/\b(?=\w*[Aa])(?=\w*[Ee])(?=\w*[Ii])(?=\w*[Oo])(?=\w*[Uu])\w+\b/';
$str = 'abceioussa
aeiou
uioae
odsidsfusjldkfuuuu
bcesdddsoaiaaau
aaaaaaaaeeeeeeeooooiu
aasssssaeeeeeeeoeoooi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);