using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=\w*[Aa])(?=\w*[Ee])(?=\w*[Ii])(?=\w*[Oo])(?=\w*[Uu])\w+\b";
string input = @"abceioussa
aeiou
uioae
odsidsfusjldkfuuuu
bcesdddsoaiaaau
aaaaaaaaeeeeeeeooooiu
aasssssaeeeeeeeoeoooi";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}