re = /\b(?=\w*[Aa])(?=\w*[Ee])(?=\w*[Ii])(?=\w*[Oo])(?=\w*[Uu])\w+\b/
str = 'abceioussa
aeiou
uioae
odsidsfusjldkfuuuu
bcesdddsoaiaaau
aaaaaaaaeeeeeeeooooiu
aasssssaeeeeeeeoeoooi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end