import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=\\w*[Aa])(?=\\w*[Ee])(?=\\w*[Ii])(?=\\w*[Oo])(?=\\w*[Uu])\\w+\\b";
final String string = "abceioussa\n"
+ "aeiou\n"
+ "uioae\n"
+ "odsidsfusjldkfuuuu\n"
+ "bcesdddsoaiaaau\n"
+ "aaaaaaaaeeeeeeeooooiu\n"
+ "aasssssaeeeeeeeoeoooi";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}