using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?\d{1,}\.\d{6}";
string input = @" 2C 6s 0.043315-143.954801 17.872676 31.277358-18.149649114.553363";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}