package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?\d{1,}\.\d{6}`)
var str = ` 2C 6s 0.043315-143.954801 17.872676 31.277358-18.149649114.553363`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}