// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-?\d{1,}\.\d{6}").unwrap();
let string = " 2C 6s 0.043315-143.954801 17.872676 31.277358-18.149649114.553363";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}