const regex = /-?\d{1,}\.\d{6}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?\\d{1,}\\.\\d{6}', 'g')
const str = ` 2C 6s 0.043315-143.954801 17.872676 31.277358-18.149649114.553363`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}