re = /-?\d{1,}\.\d{6}/
str = ' 2C 6s 0.043315-143.954801 17.872676 31.277358-18.149649114.553363'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end