import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{1,}/2020/\\w{0,}/SPV";
final String string = "Số: 2479/2020/ECOM/SPV - tabiimlianoi\n"
+ "Số: 2479/2020//SPV - tabiimlianoi\n"
+ "1712/2020/HDDVBC/SPV - VIMO - SPX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}