re = /[0-9]{1,}\/2020\/\w{0,}\/SPV/m
str = 'Số: 2479/2020/ECOM/SPV - tabiimlianoi
Số: 2479/2020//SPV - tabiimlianoi
1712/2020/HDDVBC/SPV - VIMO - SPX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end