const regex = new RegExp('[0-9]{1,}/2020/\\w{0,}/SPV', 'gm')
const str = `Số: 2479/2020/ECOM/SPV - tabiimlianoi
Số: 2479/2020//SPV - tabiimlianoi
1712/2020/HDDVBC/SPV - VIMO - SPX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}