import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-zA-Z0-9]*)\\s*=\\s*(.*?)(?=,[A-Z]|$)";
final String string = "Variable1=somevalue1,Variable2=so,me,value2,Variable3=some,value2,Variable4 = Hello, Wor,ld,d,ThisVariable=ThisOneWill,Fail,Hello=wo, rld";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}