import Foundation
let pattern = #"([A-Z][a-zA-Z0-9]*)\s*=\s*(.*?)(?=,[A-Z]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Variable1=somevalue1,Variable2=so,me,value2,Variable3=some,value2,Variable4 = Hello, Wor,ld,d,ThisVariable=ThisOneWill,Fail,Hello=wo, rld"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)