const regex = /([A-Z][a-zA-Z0-9]*)\s*=\s*(.*?)(?=,[A-Z]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z][a-zA-Z0-9]*)\\s*=\\s*(.*?)(?=,[A-Z]|$)', 'g')
const str = `Variable1=somevalue1,Variable2=so,me,value2,Variable3=some,value2,Variable4 = Hello, Wor,ld,d,ThisVariable=ThisOneWill,Fail,Hello=wo, rld`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}