re = /([A-Z][a-zA-Z0-9]*)\s*=\s*(.*?)(?=,[A-Z]|$)/
str = 'Variable1=somevalue1,Variable2=so,me,value2,Variable3=some,value2,Variable4 = Hello, Wor,ld,d,ThisVariable=ThisOneWill,Fail,Hello=wo, rld'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end