use strict;
my $str = 'Variable1=somevalue1,Variable2=so,me,value2,Variable3=some,value2,Variable4 = Hello, Wor,ld,d,ThisVariable=ThisOneWill,Fail,Hello=wo, rld';
my $regex = qr/([A-Z][a-zA-Z0-9]*)\s*=\s*(.*?)(?=,[A-Z]|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}