# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img[^>]*?alt=\x22([^\x22]*)\x22[^>]*?src=\x22([^\x22]*)[^>]*?>|<img[^>]*?src=\x22([^\x22]*)\x22[^>]*?alt=\x22([^\x22]*)\x22[^>]*?>/<figure>\n$0\n<figcaption>$1<\/figcaption\n<\/figure>/ig;t' <<< "<img title=\"Palestinian refugees escaping the 1948 palestine war\" alt=\"Palestinian refugees escaping the 1948 palestine war\" src=\"/user/sites/test.fremmed.dev/pages/featured/2016-03-30-the-stateless-refugees/1948.jpg\">"