$re = '/<img[^>]*?alt=\x22([^\x22]*)\x22[^>]*?src=\x22([^\x22]*)[^>]*?>|<img[^>]*?src=\x22([^\x22]*)\x22[^>]*?alt=\x22([^\x22]*)\x22[^>]*?>/i';
$str = '<img title="Palestinian refugees escaping the 1948 palestine war" alt="Palestinian refugees escaping the 1948 palestine war" src="/user/sites/test.fremmed.dev/pages/featured/2016-03-30-the-stateless-refugees/1948.jpg">';
$subst = "<figure>\n$0\n<figcaption>$1</figcaption\n</figure>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;