// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<img[^>]*?alt=\x22([^\x22]*)\x22[^>]*?src=\x22([^\x22]*)[^>]*?>|<img[^>]*?src=\x22([^\x22]*)\x22[^>]*?alt=\x22([^\x22]*)\x22[^>]*?>").unwrap();
let string = "<img title=\"Palestinian refugees escaping the 1948 palestine war\" alt=\"Palestinian refugees escaping the 1948 palestine war\" src=\"/user/sites/test.fremmed.dev/pages/featured/2016-03-30-the-stateless-refugees/1948.jpg\">";
let substitution = "<figure>\\n$0\\n<figcaption>$1</figcaption\\n</figure>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}