import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]*?alt=\\x22([^\\x22]*)\\x22[^>]*?src=\\x22([^\\x22]*)[^>]*?>|<img[^>]*?src=\\x22([^\\x22]*)\\x22[^>]*?alt=\\x22([^\\x22]*)\\x22[^>]*?>";
final String string = "<img title=\"Palestinian refugees escaping the 1948 palestine war\" alt=\"Palestinian refugees escaping the 1948 palestine war\" src=\"/user/sites/test.fremmed.dev/pages/featured/2016-03-30-the-stateless-refugees/1948.jpg\">";
final String subst = "<figure>\\n$0\\n<figcaption>$1</figcaption\\n</figure>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}