const regex = /<img[^>]*?alt=\x22([^\x22]*)\x22[^>]*?src=\x22([^\x22]*)[^>]*?>|<img[^>]*?src=\x22([^\x22]*)\x22[^>]*?alt=\x22([^\x22]*)\x22[^>]*?>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[^>]*?alt=\\x22([^\\x22]*)\\x22[^>]*?src=\\x22([^\\x22]*)[^>]*?>|<img[^>]*?src=\\x22([^\\x22]*)\\x22[^>]*?alt=\\x22([^\\x22]*)\\x22[^>]*?>', 'ig')
const str = `<img title="Palestinian refugees escaping the 1948 palestine war" alt="Palestinian refugees escaping the 1948 palestine war" src="/user/sites/test.fremmed.dev/pages/featured/2016-03-30-the-stateless-refugees/1948.jpg">`;
const subst = `<figure>\n$0\n<figcaption>$1</figcaption\n</figure>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);