#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d\d?|[a-zA-Z]{2,8})([:/-])(\d\d?)\2(\d{2,4})"
Local $sString = "July-21-1999" & @CRLF & _
"07/21/99" & @CRLF & _
"July 21 1999" & @CRLF & _
"07/21-1999" & @CRLF & _
"12:04:17"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")