const regex = /(\d\d?|[a-zA-Z]{2,8})([:/-])(\d\d?)\2(\d{2,4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d?|[a-zA-Z]{2,8})([:\/-])(\\d\\d?)\\2(\\d{2,4})', 'g')
const str = `July-21-1999
07/21/99
July 21 1999
07/21-1999
12:04:17`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}