$re = '/(\d\d?|[a-zA-Z]{2,8})([:/-])(\d\d?)\2(\d{2,4})/';
$str = 'July-21-1999
07/21/99
July 21 1999
07/21-1999
12:04:17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);