import Foundation
let pattern = #"(\d\d?|[a-zA-Z]{2,8})([:/-])(\d\d?)\2(\d{2,4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
July-21-1999
07/21/99
July 21 1999
07/21-1999
12:04:17
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)