using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\d?|[a-zA-Z]{2,8})([:/-])(\d\d?)\2(\d{2,4})";
string input = @"July-21-1999
07/21/99
July 21 1999
07/21-1999
12:04:17";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}