#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{0,2}:\d{2}(?:\.\d+)?)"
Local $sString = ""R uses 1:5 for 1, 2, 3, 4, 5.", " & @CRLF & _
" "At 3:00 we'll meet up and leave by 4:30:20."," & @CRLF & _
" "We'll meet at 6:33.", "He ran it in :22.34."" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")