using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{0,2}:\d{2}(?:\.\d+)?)";
string input = @"""R uses 1:5 for 1, 2, 3, 4, 5."",
""At 3:00 we'll meet up and leave by 4:30:20."",
""We'll meet at 6:33."", ""He ran it in :22.34.""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}