$re = '/(\d{0,2}:\d{2}(?:\.\d+)?)/';
$str = '"R uses 1:5 for 1, 2, 3, 4, 5.",
"At 3:00 we\'ll meet up and leave by 4:30:20.",
"We\'ll meet at 6:33.", "He ran it in :22.34."
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);