package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{0,2}:\d{2}(?:\.\d+)?)`)
var str = `"R uses 1:5 for 1, 2, 3, 4, 5.",
"At 3:00 we'll meet up and leave by 4:30:20.",
"We'll meet at 6:33.", "He ran it in :22.34."
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}