// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{0,2}:\d{2}(?:\.\d+)?)").unwrap();
let string = "\"R uses 1:5 for 1, 2, 3, 4, 5.\",
\"At 3:00 we'll meet up and leave by 4:30:20.\",
\"We'll meet at 6:33.\", \"He ran it in :22.34.\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}