$re = '/RGB = \((?:(?:\d{1,3},?){4})\)/mi';
$str = 'RGB = (255,000,255,000)
RGB = (255,255,000,000)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);