re = /RGB = \((?:(?:\d{1,3},?){4})\)/mi
str = 'RGB = (255,000,255,000)
RGB = (255,255,000,000)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end