using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\S]+@[\w]+(?:\.[\w]+)+)";
string input = @"send an email to r@m.evernote.com with subject this is what I meant. message I was talking about dinos.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}