$re = '/([\S]+@[\w]+(?:\.[\w]+)+)/i';
$str = 'send an email to r@m.evernote.com with subject this is what I meant. message I was talking about dinos.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);