re = /([\S]+@[\w]+(?:\.[\w]+)+)/i
str = 'send an email to r@m.evernote.com with subject this is what I meant. message I was talking about dinos.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end