// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([\S]+@[\w]+(?:\.[\w]+)+)").unwrap();
let string = "send an email to r@m.evernote.com with subject this is what I meant. message I was talking about dinos.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}