package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\S]+@[\w]+(?:\.[\w]+)+)`)
var str = `send an email to r@m.evernote.com with subject this is what I meant. message I was talking about dinos.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}