#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":\s*([^(\s]+)\s*\(Old=([^,]*),New=([^)]*)"
Local $sString = "ABC: Some_Field (Old=Hello World,New=Bye Bye World)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")