package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:\s*([^(\s]+)\s*\(Old=([^,]*),New=([^)]*)`)
var str = `ABC: Some_Field (Old=Hello World,New=Bye Bye World)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}