$re = '/:\s*([^(\s]+)\s*\(Old=([^,]*),New=([^)]*)/';
$str = 'ABC: Some_Field (Old=Hello World,New=Bye Bye World)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);