re = /:\s*([^(\s]+)\s*\(Old=([^,]*),New=([^)]*)/
str = 'ABC: Some_Field (Old=Hello World,New=Bye Bye World)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end