using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s*([^(\s]+)\s*\(Old=([^,]*),New=([^)]*)";
string input = @"ABC: Some_Field (Old=Hello World,New=Bye Bye World)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}