# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*[a-zA-Z])\W*(\d+)\W*$/$1/gm;t' <<< "(5)
[[12]]
{3}
#!8(#
!255=
/879/
@#@434dsd@#2"