#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*[a-zA-Z])\W*(\d+)\W*$"
Local $sString = "(5)" & @CRLF & _
"[[12]]" & @CRLF & _
"{3}" & @CRLF & _
"#!8(#" & @CRLF & _
"!255=" & @CRLF & _
"/879/" & @CRLF & _
"@#@434dsd@#2"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)