using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[a-zA-Z])\W*(\d+)\W*$";
string substitution = @"$1";
string input = @"(5)
[[12]]
{3}
#!8(#
!255=
/879/
@#@434dsd@#2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}